Selective sync doesn't work for Boxifier links

I’ve linked a Photos folder on another drive to my Dropbox folder using Boxifier. This Photos folder has several sub-folders that I do not want to sync.

However, when I go into Dropbox to use Selective Sync, the folder tree just shows:

Dropbox > Boxifier > Photos

It doesn’t show any folders below Photos for me to unselect.

Hi there,

DId the folder finish syncing? Are the subfolders visible in the web interface?

No, the folder contains about 200GB, so it will take a long time to complete the sync. Do you expect the subfolders to become visible during or after the sync?

The subfolders should become visible after the sync.

However, I do not recommended using Selective Sync on the subfolders that you want to filter out.

If you uncheck them in the Selective Sync settings Dropbox will delete those folders from your drive and you will lose those folders.

Yes, some of them do seem to be appearing when they are being synced.

Are you saying that unchecking them in Selective Sync will deleted them from my online Dropbox folder, or do you mean it will delete them from my physical disk?

When you uncheck a folder It will delete the entire folder from your physical disk. This is the way Selective Sync works in Dropbox.

Yikes, I didn’t realise that! That seems a rather strange way to do it.

Is there some other way I can exclude these folders, or even file types, using Boxifier?

Not at the moment, but we have a solution for it. We are working on getting it into the product as we’ve received requests for supporting exclusions and we think it would be a good addition to the product.

It would indeed be a great addition - any ETA?

Sorry, no ETA for now. If you would like to help us get that faster into the product, we would appreciate your help with spreading the word about Boxifier. Thanks!

Can you share the details of your proposed solution then, so I can try to hack something temporary together for myself until it’s added to Boxifier?

For the moment you could use this workaround:

  1. Let’s say you have a subfolder named “Alice” inside a folder that you sync with Boxifier.
  2. Move all the files and folders inside “Alice” to somewhere outside of the folder that you sync with Boxifier.
  3. At this point your “Alice” folder should be empty.
  4. Use Selective Sync to uncheck the “Alice” folder. Since it is empty, there is nothing to be deleted from it.
  5. Wait for the selective sync settings to be applied.
  6. Move back the files and folders that you moved from “Alice”.

Just tried this method, and it does seem to work !

I have quite a few folders to exclude, but their naming all follows a pattern, so I whipped up a simple batch file to move them outside of the Boxfier folder and create empty dummy folders in their place.

Once the sync has finished, I’ll use Selective Sync to exclude the dummy folders, and then use another batch file to move the contents back.