New version 1.4.6 won't install


I got the notification to download and install v1.4.6. The download happened and I have a green bar in the settings but when I click the Install button nothing happens. I also get a pop up message to say the new version is ready to install but nothing happens when I click the install now button.

I am currently on v1.3.0 Boxifier Plus running on Windows 10

What am I doing wrong?


Thank you for reporting this, Roger. We are looking into it.

The update is downloaded into %APPDATA%\Boxifier\Updates

As a workaround, could you please see if you have it there and run it manually?

And as usual, is not updated. :sleeping:

Hi Razvan, several of my friends have the same issue with 1.4.6… When are you guys going to fix this ???

Thank you for reporting this, Peter.

As a workaround, please download and install Boxifier 1.4.6 from here:

You can install it on top of your existing installation.

Hi Razvan

I cannot find folder you suggested on my machine>

Hi Razvan

that has fixed it - thanks for your help.


Stops downloading after 0.5 MB… Tried 4 x times…

Peter, that sounds like an issue with your internet connection. Maybe you could you try downloading it on another connection?

@neko: we focus our efforts on first improving the product and then updating the change log.

Thank you for your understanding!