[FIXED] Application Error

Hi all. First night using Boxifier and I’ve had a pretty significant crash. “Exception EAccessViolation in module boxifier.exe at 0072BA0E. Access violation at address 00B2BA0E in module ‘boxifier.exe’. Read of address 00000008.” Error message comes back repeatedly. I’ve gone so far as to uninstall both dropbox and boxifier, hard reboot, and reinstall - same result. Ideas welcome!


1 Like

That’s quite a coincidence. I’ve been using Boxifier for several years without issue but when I rebooted my computer this evening I got the same error message (albeit at a different memory address).

1 Like

same problem for me. lastnight i moved my dropbox folder to another (partition of my) drive, dropbox is going well, buy boxifier is not starting up.
some suggestions?

Same problem here. After reboot I get the same error.

In case it helps with troubleshooting, I just just downloaded the Windows setup exe, installed it, and Bam! 'Exception EAccessViolation…'
First Boxifier installation ever on this PC.
Windows 7 64 bit.

I made an exception for Boxifier.exe in Windows DEP (Data Execution Prevention) but it didn’t solve the problem.

(Win 10, 64 bit)

Hi everyone,

We are looking into this as it started happening in the last 12 hours.

I will get back with an update as soon as we have more details.

Please note that this error affects only the Graphical User Interface of Boxifier, so your files should continue syncing without any issues.

Hello, i have the same problem since this morning.
Thanks, Michael

We found out this happens due to a leap-year-bug in a third-party library that Boxifier uses. The reason why it happens today is because that library internally computes the “one-year-from-now date” by incorrectly adding 1 to the current year. So in this case today (2016-02-29) it incorrectly computes the one-year-from-now date as 2017-02-29 which is an invalid date, because 2017 is not a leap year. It then crashes because it uses another function to encode that date in another format, but that function rejects the invalid date. We have contacted the third-party vendor of this library in order to get a fix for this bug.

The problem will “magically” disappear tomorrow on the 1st of March.

Please note that due to the way Boxifier has been designed, this bug affected just the graphical interface component of Boxifier, so the sync component was not affected.

One thing you can do for now is to close Boxifier from the tray icon menu. This will close the graphical interface but not the sync component so your files should continue syncing. You can then restart Boxifier graphical interface (boxifier.exe) tomorrow on the 1st of March.

1 Like

Thanks for tracking that down for us.

1 Like

Hello everyone,

There is a new setup that you can install from here:


Please let us know if this fixes the issue.

1 Like

It worked! Thanks a lot!

1 Like

The update works fine.

Thanks for responding quickly!

1 Like

Awesome. Thanks for the quick response!

1 Like

Great to find a fix for this on my first search after the error on it this morning. Thanks for having it ready so quickly!


Worked for me too! Thanks!