Cannot rename 'non top-level' folder


Greetings all and thanks in advance,

When I create folders that are nested within the top-level sync folder, I cannot rename those folders. For example, I will right-click within the top-level folder and create a new folder. I’m given the opportunity to name the folder to something other than “new folder”. I provide the name, hit enter, it applies but then is quickly reverted back to New Folder.

Server 2012 R2, Boxifier 1.6.8

If I stop the sync to Dropbox on the root folder, the ability to rename folders is restored.




If I got this right, you are syncing a folder with Boxifier and in that folder you create a new folder using Windows Explorer and when you try to name it the name gets back to “New Folder”. Does this accurately describe what you are experiencing?

What is the version of Dropbox currently running on the server?


Hi Razvan,

Yes, you understand correctly. Dropbox version 26.4.24

Thank you,



Thank you for the details. We will try to reproduce this behaviour with our testing environment in order to find out more about it and I will update this thread.

In the meantime, could you please try the following?

  1. Go to Boxifier settings and uncheck “Block Dropbox updates”
  2. Wait for Dropbox to automatically update to the latest version (31.4.24)
  3. Try creating a folder and report if you still experience the behavior that you described.


Hi Razvan,

Is there anything I can do to initiate the Dropbox upgrade. Let it sit overnight, but still riding at ver 26.4.24.




Yes, you could manually download and install the latest version of Dropbox:

Does the installer run and update if you try this way?


Good morning Razvan,

As silly as this sounds, I cannot get the Dropbox installer to run. I’ve tried as myself and I’ve as the Boxifier account, both of which are admins on the machine. I’ve tried to run it with elevated permissions and from a command line with elevated permissions. I’ve even restarted the server, but nothing. It gets as far as asking me ‘if I want to run this file’. I say run and it just drops. I’ve stopped the Boxifier service, but perhaps I’ve not stopped it the correct way.



Maybe the “Block Dropbox updates” setting is not unchecked yet? One other thing to try is to go to %PROGRAMDATA%\Boxifier and delete the config file.


Did you try this first?